Project

General

Profile

Bug #2303

Plutonia 2: Incorrect music; "unknown" map author (with embedded DEHACKED lump)

Added by sonicdoommario 10 months ago. Updated 6 days ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
Regression
Target version:
Start date:
2018-12-13
% Done:

80%

Tags:

Description

While playing through Plutonia 2 there are some parts of the game that play the incorrect music. For example, the title screen plays the music of Map03, when it normally plays "On the Hunt" (Doom E1M6). Also, the music for Map04 plays the music of Map01, when the song for that map is "The Imp's Song" (Doom E1M2).

MAPINFO.lmp (4.92 KB) MAPINFO.lmp xe_sued, 2018-12-15 18:17
MAPINFO.lmp (4.92 KB) MAPINFO.lmp xe_sued, 2018-12-15 18:19

Associated revisions

Revision 7cbb47f3 (diff)
Added by skyjake 10 months ago

importidtech1: Updated MAPINFO parser with "map.sucktime"

Ignore the "map.suckTime" directive gracefully.

IssueID #2303

Revision bc0c34b1 (diff)
Added by skyjake 10 months ago

Audio|Log: Print to log which music lump/file/track is started

IssueID #2303

Revision da944864 (diff)
Added by skyjake 10 months ago

importidtech1: Updated MAPINFO parser with "map.sucktime"

Ignore the "map.suckTime" directive gracefully.

IssueID #2303

Revision ea9850d4 (diff)
Added by skyjake 10 months ago

Audio|Log: Print to log which music lump/file/track is started

IssueID #2303

History

#1 Updated by skyjake 10 months ago

  • Category set to Regression
  • Assignee set to skyjake
  • Target version set to 2.1.1

#2 Updated by sonicdoommario 10 months ago

I did a little digging into this issue, since I know Plutonia 2 (pl2.wad) has a built in Dehacked/MAPINFO lump and it changes the names of the music files (nearly all of which are built into pl2.wad, so the rest of the tracks in this game play fine in Doomsday).

For the Map04 music, the MAPINFO lump directs Map04 to use D_RUNNIN for its track. D_RUNNIN is the track name used for Map01 of Doom II-based games, but there is no D_RUNNIN entry in pl2.wad. It looks like Vanilla Doom treats this case by using D_RUNNIN from Plutonia.wad, which is in fact "The Imp's Song" (Doom E1M2).

For the title screen issue, the Dehacked lump (and the separate .deh file) renames DM2TTL (the filename for the title screen music) to COUNTD (the track name for Map03 of Doom II-based games). There is no D_COUNTD entry in pl2.wad, so it looks like it would resort to D_COUNTD in plutonia.wad, which the song there is "On the Hunt" (Doom E1M6).

#3 Updated by skyjake 10 months ago

Took a quick initial look. At least the MAPINFO is failing to parse. It stops reading the MAPINFO after it encounters the "sucktime" property. I'll fix that problem and then see how the music is being translated...

#4 Updated by skyjake 10 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

#5 Updated by skyjake 10 months ago

Is this fixed in build 2904? If I understood you correctly:
  • PL2 title music should be d_countd, and
  • PL2 map 4 music should be d_runnin.

At least those are playing for me in 2904 (MUS music lumps, not external).

#6 Updated by xe_sued 10 months ago

#7 Updated by xe_sued 10 months ago

xe_sued wrote:

skyjake

Confirmed, the music definition for the PL2 title and Map04 is correct. Find attached the mapinfo.lmp of PL2, which contains the music definitions for the individual maps. The title music is not defined in there, but the dehacked.lmp found on PL2.WAD contains an entry "Text 6 6 dm2ttlcountd".

#8 Updated by xe_sued 10 months ago

#9 Updated by sonicdoommario 10 months ago

I tested in build 2904. Initially it wasn't working, but when I loaded in Plutonia 2 by itself, it then worked properly. It doesn't work if the separate Dehacked file for Plutonia 2 (pl2.deh) is also loaded in.

#10 Updated by skyjake 10 months ago

I think PL2.WAD contains a DEHACKED lump that gets loaded automatically. It seems likely that loading the DEH patch a second time may cause some unpredictable issues.

#11 Updated by skyjake 10 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 10 to 100

#12 Updated by sonicdoommario 10 months ago

I'd like to reopen this, if possible. I found another error with the soundtrack in Plutonia 2, this time with Map23. The MAPINFO lump tells Map23 to use D_ROMER2, which is the Map27 music filename. In Plutonia, Map27 is "I Sawed the Demons" (Doom E2M1), but it plays the Map27 music from Plutonia 2 instead.

Also, when loading Plutonia 2 without the separate DEH file, the word "unknown" appears at the bottom of the map title when starting a map.

#13 Updated by skyjake 10 months ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 80

#14 Updated by skyjake 10 months ago

  • Subject changed from Incorrect music played in parts of Plutonia 2 to Incorrect music played in parts of Plutonia 2; "unknown" map author displayed

#15 Updated by skyjake 10 months ago

  • Subject changed from Incorrect music played in parts of Plutonia 2; "unknown" map author displayed to Plutonia 2: Incorrect music; "unknown" map author (with embedded DEHACKED lump)

#16 Updated by skyjake 8 months ago

  • Target version changed from 2.1.1 to 2.1.2

#17 Updated by skyjake 6 days ago

  • Target version changed from 2.1.2 to 2.2 (2019)

Also available in: Atom PDF