Project

General

Profile

Bug #2227

[HeXen] Crash during gameplay at DK_Map08 (Constable gate), going through portals while Heresiarch is attacking

Added by theleo_ua over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2017-04-01
% Done:

100%

Tags:

Description

[HeXen] Crash during gameplay with addons at DK_Map08 (Constable gate)

1) Download next addons: https://drive.google.com/file/d/0BygbyP4_qEiTb3hIUTRXME9DdVU/view?usp=sharing
2) Turn them on for Hexen (use default options for TXHD and turn on all 5 packages from veirdo's 2.0 pack). If TXHD is not displayed, please use this trick: https://tracker.dengine.net/issues/2225
3) Play Hexen DK till Map08 (Constable gate) like in this video: https://www.youtube.com/watch?v=0dwrPGDzqK8&index=1&list=PL5QwAqOy7WABpsDsuzSKwTk2S8QnzsLg5#t=4h47m55s (crash happened at 4:47:55)

Reproduced in 2.0.0.2278 x64 (Windows 7 x64 Ultimate)

CFG + Logs: https://drive.google.com/file/d/0BygbyP4_qEiTeEF2OE1ud2gtVkk/view?usp=sharing

NOTE: I will investigate better steps to reproduce (for example without addons) and add them in comments if I find

CFG+LOGS.7z (377 KB) CFG+LOGS.7z theleo_ua, 2017-04-01 16:54
SAVEGAME_EXAMPLE.zip (113 KB) SAVEGAME_EXAMPLE.zip theleo_ua, 2017-04-23 08:16

Related issues

Related to Bug #2068: [HeXen] Badguys not retaining alerted status upon return to a mapNew2015-05-21

Associated revisions

Revision 82d78857 (diff)
Added by skyjake about 2 years ago

Fixed|Hexen: Crash when going through portals while Heresiarch attacks

Prepare for a temporarily missing attack target.

IssueID #2227

Revision 07a44827 (diff)
Added by skyjake about 2 years ago

Fixed|Hexen: Crash when going through portals while Heresiarch attacks

Prepare for a temporarily missing attack target.

IssueID #2227

History

#1 Updated by skyjake over 2 years ago

  • Tags set to Deathkings
  • Category set to Defect
  • Assignee set to skyjake

#2 Updated by skyjake over 2 years ago

  • Target version set to 2.0.1

#3 Updated by skyjake about 2 years ago

  • Status changed from New to Progressed
  • Target version changed from 2.0.1 to Vanilla / Gameplay
  • % Done changed from 0 to 10

I spent some time replicating that exact same situation where the crash occurred, but it didn't crash for me. I also kept playing through the rest of the hub without any issues.

It is possible that this is one of those "bad luck" situations where the map was left in a particular rare state that caused the crash when it was reloaded.

Let me know if this kind of a crash happens again, maybe we can pinpoint the circumstances better.

#4 Updated by theleo_ua about 2 years ago

skyjake wrote:

I spent some time replicating that exact same situation where the crash occurred, but it didn't crash for me. I also kept playing through the rest of the hub without any issues.

It is possible that this is one of those "bad luck" situations where the map was left in a particular rare state that caused the crash when it was reloaded.

Let me know if this kind of a crash happens again, maybe we can pinpoint the circumstances better.

I reproduced the crash, even without packages: just wait while heresiarch will start his attack sequence and go to the portal to another level before he will throw any fireball. Then go to this map again (through portal), and doomsday will crash

If you still cannot reproduce and/or need video with reproducing or doomsday.out, please tell me

So, as I understand, this should be reproducible in any map with heresiarch, but DK_map08 is easiest because you can type locksmith cheat for keys and open portal to another level exact in the same room where heresiarch is located

#5 Updated by skyjake about 2 years ago

theleo_ua wrote:

I reproduced the crash, even without packages: just wait while heresiarch will start his attack sequence and go to the portal to another level before he will throw any fireball. Then go to this map again (through portal), and doomsday will crash

Ah, that narrows it down considerably yes. It would be very helpful if you could save the game and give me a copy of the savegame files from the moment after you've gone through the portal, leaving Heresiarch in its bad state. That should allow me to easily replicate the crash. (Without addons.)

#6 Updated by theleo_ua about 2 years ago

Added 2 savegames (one before portal and second before crash)

#7 Updated by skyjake about 2 years ago

Thank you! :) I'm now looking at the crash in the debugger, looks like Heresiarch forgot about its attack target during those portal jumps. Should be fixable...

#8 Updated by skyjake about 2 years ago

  • Status changed from Progressed to Resolved
  • Target version changed from Vanilla / Gameplay to 2.0.1
  • % Done changed from 10 to 100

I've applied a fix that avoids the crash at least for me. It will be available in the next 2.1 unstable build, and also stable 2.0.1. Thanks again for the help.

#9 Updated by skyjake about 2 years ago

  • Subject changed from [HeXen] Crash during gameplay with addons at DK_Map08 (Constable gate) to [HeXen] Crash during gameplay at DK_Map08 (Constable gate), going through portals while Heresiarch is attacking

#10 Updated by vermil about 2 years ago

This is part of this bigger bug in Dday: https://tracker.dengine.net/issues/2068

#11 Updated by skyjake about 2 years ago

  • Related to Bug #2068: [HeXen] Badguys not retaining alerted status upon return to a map added

#12 Updated by skyjake about 2 years ago

Indeed, #2068 needs fixing in the near future...

#13 Updated by skyjake about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF