Project

General

Profile

Bug #2225

Some packages are not displayed in package list until tricky editing info file

Added by theleo_ua over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2017-04-01
% Done:

100%

Tags:

Description

Some packages are not displayed in package list until tricky editing info file

1.1) Run doomsday, clear cache and exit doomsday
1.2) Download TXHD pack https://drive.google.com/file/d/0BygbyP4_qEiTZ2lhUnhsSl9yVFE/view?usp=sharing and unzip it to doomsday /data folder
1.3) Run doomsday and go to Hexen menu item

Actual result: TXHD package is not displayed in packages list
Expected result: TXHD package should be displayed in packages list

2.1) Close doomsday
2.2) Edit "TXHD__0_01.BOX/info" file: remove all "TEXTURES_blablabla" categories from it (remove strings from 43 to 87)
2.3) Run doomsday and go to Hexen menu item

Actual result: TXHD package is displayed in packages list

3.1) Close doomsday
3.2) Edit "TXHD__0_01.BOX/info" file: restore all "TEXTURES_blablabla" categories back (restore all strings from 43 to 87, or just copy original info file from 7-zip archive from step 1.2)
3.3) Run doomsday and go to Hexen menu item

Actual result: TXHD package is displayed in packages list (with "texture" categories in package options menu)

4.1) Select TXHD package (so it will load when starting hexen)
4.2) Go to TXHD package options menu
4.3) Find category "MODELS_I_DISC_OF_REPULSION"
4.4) Leave default value here (XARP version) and run hexen original on map06

Actual result: XARP version (round model) of disc of repulsion appears on map06

5.1) Restart doomsday and go to Hexen menu item
5.2) Go to TXHD package options menu
5.3) Find category "MODELS_I_DISC_OF_REPULSION"
5.4) Select ALT value here (1.8.6 version) and run hexen original on map06

Actual result: XARP version (round model) of disc of repulsion appears on map06
Expected result: 1.8.6 version ("square" model) of disc of repulsion should appear on map06

6.1) Close doomsday
6.2) Move the file MODELS__I-DISC_OF_REPULSION__1_8_6.PK3 from EXTRA folder to the root folder, and MODELS__I-DISC_OF_REPULSION__XARP.PK3 from root folder to the EXTRA folder
6.3) Run doomsday and run hexen original on map06

Actual result: 1.8.6 version ("square" model) of disc of repulsion appears on map06

Reproduced in 2.0.0.2278 x64 (Windows 7 x64 Ultimate)

CFG + Logs: https://drive.google.com/file/d/0BygbyP4_qEiTN0JnMm9EX3lzMms/view?usp=sharing

CFG+LOGS.7z (337 KB) CFG+LOGS.7z theleo_ua, 2017-04-01 00:44

Related issues

Related to Bug #2250: Crash on launch when trying to index folders with lots of files, or files with unexpected names/contentClosed2017-06-19

Associated revisions

Revision d8499696 (diff)
Added by skyjake over 2 years ago

Fixed|Resources|libdoomsday: Handle syntax errors in Snowberry-format metadata

Malformed packages get the "error" tag and the error message is included
in the package notes.

IssueID #2225

Revision 83c182bd (diff)
Added by skyjake over 2 years ago

Fixed|Resources|libdoomsday: Handle syntax errors in Snowberry-format metadata

Malformed packages get the "error" tag and the error message is included
in the package notes.

IssueID #2225

History

#1 Updated by skyjake over 2 years ago

  • Tags set to Packages
  • Category set to Defect
  • Assignee changed from Deng Team to skyjake

#2 Updated by skyjake over 2 years ago

  • Target version set to 2.0.1

#3 Updated by skyjake over 2 years ago

  • Status changed from New to Progressed
  • % Done changed from 0 to 30

The first issue is that "TXHD__0_01.BOX/info" has a syntax error due to parentheses not being allowed in key identifiers. I have changed the parser so that it reports the syntax error in the package popup instead of hiding the package completely.

I will return to the other issues later. In general, Snowberry categories are not fully supported yet in the Packages list.

#4 Updated by theleo_ua over 2 years ago

skyjake wrote:

The first issue is that "TXHD__0_01.BOX/info" has a syntax error due to parentheses not being allowed in key identifiers. I have changed the parser so that it reports the syntax error in the package popup instead of hiding the package completely.

I will return to the other issues later.

So, for make this to work properly in current 2.0 build, I should replace all () with [], am I right?

skyjake wrote:

In general, Snowberry categories are not fully supported yet in the Packages list.

Which workaround I can do in current 2.0 build? Or you mean, that I should wait while you add full support for categories?

Also next thing is still not clear for me: what is intended use of package formats you planned to implement in future versions for MD2 models, sounds, textures and other "hires/HD" data, which were created years ago? For example, should veirdo convert xarp (which contains a lot of MD2 stuff) from snowberry format to new package format in future versions of doomsday? Or you plan to support xarp-like package formats for long time, and this format is intended format for old MD2 stuff?

#5 Updated by skyjake over 2 years ago

theleo_ua wrote:

So, for make this to work properly in current 2.0 build, I should replace all () with [], am I right?

Yes, as far as parsing the info file is concerned, [] are the only brace characters that are allowed in key identifiers. () and {} are used for blocks, <> is used for lists.

However, note that these category strings in the box's info file are not currently used by Doomsday. The only categories that are used are the ones specified in the individual packages' info files. See this page for details: http://dengine.net/manual/modding/resource_packaging_guidelines#example

Which workaround I can do in current 2.0 build? Or you mean, that I should wait while you add full support for categories?

I believe the currently supported package categorization (as described on the linked page above) is sufficient for now.

Also next thing is still not clear for me: what is intended use of package formats you planned to implement in future versions for MD2 models, sounds, textures and other "hires/HD" data, which were created years ago? For example, should veirdo convert xarp (which contains a lot of MD2 stuff) from snowberry format to new package format in future versions of doomsday? Or you plan to support xarp-like package formats for long time, and this format is intended format for old MD2 stuff?

The plan is that Snowberry-format resource packs and add-ons should be usable in Doomsday 2 without modifications. They may report errors and warnings about things that were not previously verified, but overall packages using old formats should work. (At the moment there may still be bugs like this #2225 that prevent doing this, but I will fix such bugs.)

When it comes to MD2 models in particular, they currently still need to be packaged as PK3 files, even though that PK3 is then stored inside a Doomsday 2 ".pack" package. In other words, obsolete resource formats will continue to require old package formats for the foreseeable future.

So, to summarize, old packages like XARP should not and need not be updated to Doomsday 2 packages unless they are also updated to include resources that use Doomsday 2 features like FBX models.

#6 Updated by skyjake over 2 years ago

  • Target version changed from 2.0.1 to 2.0.2

#7 Updated by skyjake over 2 years ago

  • Related to Bug #2250: Crash on launch when trying to index folders with lots of files, or files with unexpected names/content added

#8 Updated by skyjake over 2 years ago

  • Target version changed from 2.0.2 to 2.0.3

#9 Updated by skyjake over 2 years ago

  • Target version changed from 2.0.3 to 72

#10 Updated by skyjake over 2 years ago

  • Target version changed from 72 to 74

#11 Updated by skyjake over 1 year ago

  • Target version changed from 74 to 72

#12 Updated by skyjake about 1 year ago

  • Status changed from Progressed to Resolved
  • Target version changed from 72 to 2.1 (Late 2018)
  • % Done changed from 30 to 100

Marking this as resolved. A number of improvements have been made to package management, including automatic updating of metadata whenever the engine is upgraded. Metadata is also parsed more robustly and better unique package IDs are being chosen. A bug with file system refresh was also fixed, so Doomsday detects when files have been edited at runtime.

A new issue with updated details should be submitted if problems of this type still persist with 2.1.

#13 Updated by skyjake about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF