Project

General

Profile

Bug #2083

[Hexen] Spurious warning messages about music ("ignoring unknown music in TranslatedMapinfos")

Added by theleo_ua over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
User experience
Target version:
Start date:
2015-06-08
% Done:

100%


Description

strange warning messages in hexen "unknown music X in Y on line Z"

Steps to reproduce:

1) Run hexen

Actual result: strange warning messages in hexen "unknowm music X in Y on line Z" (see attached message2.jpg)
Expected result: due to fact that music is played correctly, there should not be such messages

messages2.jpg (410 KB) messages2.jpg theleo_ua, 2015-06-08 02:50
doomsday.out (17.3 KB) doomsday.out theleo_ua, 2015-06-08 02:51

Related issues

Related to Feature #2093: Processing definitions generated from MAPINFO in ZDoom vs. Hexen modeNew2015-06-19

Associated revisions

Revision eff9f25f (diff)
Added by skyjake over 5 years ago

Fixed|Hexen: Spurious warnings about ignored music definitions

IssueID #2083

Revision c35214ba (diff)
Added by skyjake over 5 years ago

Fixed|Hexen: Omit warnings about music definitions from MAPINFO

Temporary workaround.

IssueID #2083
IssueID #2093

History

#1 Updated by theleo_ua over 5 years ago

#2 Updated by skyjake over 5 years ago

  • Tags set to Music, Definitions
  • Category changed from Regression to User experience
  • Assignee changed from skyjake to Deng Team
  • Priority changed from Lowest to Normal

#3 Updated by skyjake over 5 years ago

  • Tags changed from Music, Definitions to Music, Definitions, Hexen

#4 Updated by skyjake over 5 years ago

  • Subject changed from strange warning messages in hexen "unknown music X in Y on line Z" to [Hexen] Spurious warning messages about music ("ignoring unknown music in TranslatedMapinfos")

Perhaps this should be a Developer warning, since the user can't do much about it.

#5 Updated by skyjake over 5 years ago

The warnings are printed because the definitions translated from MAPINFO are parsed before the game's music definitions.

#6 Updated by theleo_ua over 5 years ago

Also, as you can see in attached doomsday.out, there are additional warnings for sprites:

ResourceSystem: Ignoring invalid sprite name 'ARTIPTN2'
^ : Ignoring invalid sprite name 'ARTISOAR'
^ : Ignoring invalid sprite name 'ARTIINVU'
^ : Ignoring invalid sprite name 'ARTIPORK'
^ : Ignoring invalid sprite name 'ARTISPHL'
^ : Ignoring invalid sprite name 'ARTITRCH'
^ : Ignoring invalid sprite name 'ARTIATLP'
^ : Ignoring invalid sprite name 'ARTISUMN'
^ : Ignoring invalid sprite name 'ARTIPSBG'
^ : Ignoring invalid sprite name 'ARTISPED'
^ : Ignoring invalid sprite name 'ARTIBMAN'
^ : Ignoring invalid sprite name 'ARTIBRAC'
^ : Ignoring invalid sprite name 'ARTITELO'
^ : Ignoring invalid sprite name 'ARTIBLST'
^ : Ignoring invalid sprite name 'ARTISKLL'
^ : Ignoring invalid sprite name 'ARTIBGEM'
^ : Ignoring invalid sprite name 'ARTIGEMR'
^ : Ignoring invalid sprite name 'ARTIGMG2'
^ : Ignoring invalid sprite name 'ARTIGMB2'
^ : Ignoring invalid sprite name 'ARTIBOK1'
^ : Ignoring invalid sprite name 'ARTIBOK2'
^ : Ignoring invalid sprite name 'ARTISKL2'
^ : Ignoring invalid sprite name 'ARTIFWEP'
^ : Ignoring invalid sprite name 'ARTICWEP'
^ : Ignoring invalid sprite name 'ARTIMWEP'
^ : Ignoring invalid sprite name 'ARTIGEAR'
^ : Ignoring invalid sprite name 'ARTIHRAD'

#7 Updated by danij over 5 years ago

The sprite name warnings are the result of these resources being misplaced in the Hexen IWAD - they are marked up as sprites. A warning is generated for the benefit of mod authors, although we could perhaps suppress them if the same issue exists in an IWAD.

#8 Updated by skyjake over 5 years ago

Since the music warnings can't be fully fixed in 1.15.1, I'll just make prevent them from being printed when processing the definitions translated from MAPINFO.

#9 Updated by skyjake over 5 years ago

  • Related to Feature #2093: Processing definitions generated from MAPINFO in ZDoom vs. Hexen mode added

#10 Updated by skyjake over 5 years ago

  • Status changed from New to In Progress

#11 Updated by skyjake over 5 years ago

  • Assignee changed from Deng Team to skyjake

#12 Updated by skyjake over 5 years ago

  • % Done changed from 0 to 100

#13 Updated by skyjake over 5 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF