Project

General

Profile

Bug #2157

[Hexen] Rotating doors are only rotating once in Heresiarch Seminary (ACS gets stuck waiting for notification)

Added by theleo_ua over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Regression
Start date:
2016-04-05
% Done:

100%

Tags:

Description

Hexen: Rotating doors are only rotating once in Heresiarch Seminary, so it's impossible to get icon of the defender and part3 of weapon 4 at the single run

1) Go to map13 (visit13 cheat is acceptable)
2) Go to the room where exit to "orchard of lamentations" located
3) Destroy 2 trees, which hiding a button, then press this button

Actual result: Rotating doors are only rotating once
Expected result: Rotating doors should be rotated multiple times, as in vanilla

4) Try to pickup part3 of weapon 4 (or icon of the defender)

Actual result: it's impossible now to pickup icon of the defender (or part3 of weapon 4)
Expected result: should be possible to pickup both icon of the defender and part3 of weapon 4

Associated revisions

Revision 2a8fb308 (diff)
Added by skyjake almost 3 years ago

Fixed|Hexen: Doors in map 13 rotate only once

Removed a seemingly unnecessary check in p_mapspec.cpp that sometimes
prevented scripts from being notified about the completion of polyobj
rotation.

Whenever the polyobj/sector notification functions are called, the
corresponding thinker is immediately destroyed afterwards. If this
notification is ignored, ACS scripts will miss the notification
completely since a second try never occurs.

IssueID #2157

History

#1 Updated by theleo_ua over 3 years ago

reproduced in 1.15.8

#2 Updated by skyjake about 3 years ago

  • Tags set to Hexen, Gameplay
  • Subject changed from Hexen: Rotating doors are only rotating once in Heresiarch Seminary to [Hexen] Rotating doors are only rotating once in Heresiarch Seminary
  • Category set to Defect
  • Assignee changed from Deng Team to skyjake
  • Target version set to 2.0 – Home UI & Packages

#3 Updated by skyjake about 3 years ago

  • Priority changed from Normal to High

#4 Updated by theleo_ua almost 3 years ago

I started playing Deathkings with 1.15.8, and noticed, that map03 sump contains "moving columns" with strange behavior which can "ruin your savegame". There are 3 flame masks on that map, and 2 of them can be picked up only if those "moving columns" starting to move.

The bug is next: while one of the columns starting to move after I use flame mask on wall and finish respective third of the map, second column doesn't want to start to move (after finishing second third of map03), so it's impossible to collect all 3 flame masks in level.

Workaround:
1) collect emerald and swamp key on map02
2) go to map06 brackenwood
3) find exit to map03 and go to map03 from map06 brackenwood
4) respective walls are moving so you can collect "hidden" flame mask now
5) finish all map03 as usual, so now you can collect all 3 flame masks, because second "moving columns" will move

Question: is this related to rotating doors in map13, or should be separate issue?

#5 Updated by skyjake almost 3 years ago

  • Status changed from New to In Progress

#6 Updated by skyjake almost 3 years ago

  • Category changed from Defect to Regression

#7 Updated by skyjake almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#8 Updated by skyjake almost 3 years ago

theleo_ua wrote:

Question: is this related to rotating doors in map13, or should be separate issue?

It could be related. The problem was that scripts were not always being notified of sectors and polyobjs finishing their movement. If a script was waiting for this notification, they may have gotten stuck. Please test again when the new build is available.

#9 Updated by skyjake almost 3 years ago

  • Subject changed from [Hexen] Rotating doors are only rotating once in Heresiarch Seminary to [Hexen] Rotating doors are only rotating once in Heresiarch Seminary (ACS gets stuck waiting for notification)

#10 Updated by skyjake almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF