Project

General

Profile

Bug #1884

Current MP game not automatically disconnected when connecting to a new server (unable to switch between servers on the same IP address)

Added by vermil over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2014-10-19
% Done:

100%


Description

One can't join a different server on the same IP address.

Dday doesn't switch servers and the alert log incorrectly informs one that they are already connected.

Associated revisions

Revision bacb907a (diff)
Added by skyjake about 9 years ago

Fixed|Multiplayer: Joining fails with a message "already joined"

If the game mode did not change, nobody was making sure that the
current MP game was disconnected.

IssueID #1884

History

#1 Updated by skyjake about 9 years ago

  • Tags set to Multiplayer, Client
  • Subject changed from [Multi] Unable to switch between servers on the same IP address to Unable to switch between servers on the same IP address
  • Category set to Defect
  • Status changed from New to In Progress
  • Assignee set to skyjake
  • Target version set to 1.15

#2 Updated by skyjake about 9 years ago

The IP address is actually not the problem. The problem is that only a game mode change will automatically disconnect from the current game. The correct behavior would be to always disconnect the current MP game before initiating a new connection.

#3 Updated by skyjake about 9 years ago

  • Subject changed from Unable to switch between servers on the same IP address to Current MP game not automatically disconnected when connecting to a new server (unable to switch between servers on the same IP address)

#4 Updated by skyjake about 9 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#5 Updated by skyjake about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF