Project

General

Profile

Bug #1853

[Doom] Platform movement sound origin

Added by vermil almost 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Regression
Target version:
-
Start date:
2014-08-14
% Done:

100%

Tags:

Description

Platform movement sounds in the latest unstable build (1318) are all playing at 0,0 instead of the centre of the sector moving.


Related issues

Related to Bug #1855: [XG] Dummything not fully initializedClosed2014-08-15

Related to Bug #2056: Moving platforms sound origin incorrectNew2015-05-16

Associated revisions

Revision 4c8eaa02 (diff)
Added by skyjake almost 6 years ago

Fixed|World|Plane: Accessing plane sound origins

The sound emitter property was being accessed as a pointer to ThinkerT
rather than a pointer to ddmobj_base_t.

IssueID #1853

History

#1 Updated by vermil almost 6 years ago

vermil wrote:

Platform movement sounds in the latest unstable build (1318) are all playing at 0,0 instead of the centre of the sector moving.

To correct, Doom and Heretic (HeXen doesn't appear to be) are affected and all sector based sounds in those games other than switch sounds (which continue to incorrectly play in the centre of the sector the switch trigger is attached to, rather than the players location) appear to be affected (i.e doors opening and closing).

#2 Updated by skyjake almost 6 years ago

  • Tags set to Audio, MapData
  • Category set to Regression
  • Assignee set to skyjake
  • Priority changed from Normal to High

#3 Updated by skyjake almost 6 years ago

Could have something to do with sound origins now using the new Thinker class.

#4 Updated by skyjake almost 6 years ago

  • Target version set to 49

#5 Updated by skyjake almost 6 years ago

  • Related to Bug #1855: [XG] Dummything not fully initialized added

#6 Updated by skyjake almost 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#7 Updated by skyjake almost 6 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from skyjake to vermil

#8 Updated by skyjake almost 6 years ago

Please retest with the next unstable build.

#9 Updated by vermil almost 6 years ago

This issue seems fixed; well it appears to match 1.8.6 in all the places I tested.

#10 Updated by skyjake almost 6 years ago

  • Status changed from Feedback to Closed
  • Assignee changed from vermil to skyjake

#11 Updated by skyjake about 5 years ago

  • Related to Bug #2056: Moving platforms sound origin incorrect added

#12 Updated by skyjake about 5 years ago

  • Target version deleted (49)

Also available in: Atom PDF