Project

General

Profile

Bug #890

[Windows] Crash caused by SDL_mixer

Added by danij about 14 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Defect
Target version:
-
Start date:
2010-04-09
% Done:

0%

Tags:

Description

Under Windows SDL_mixer will regularly cause a seemingly random crash (typically in mipmap.dll). This can fixed by forcing the process affinity: SetProcessAffinityMask

Labels: System

History

#1 Updated by filipetolhuizen about 14 years ago

Hmm, mine wasn't that random. It crashed exactly on the 3rd time the midi was about to repeat. Using an older version of SDL_Mixer.dll (1.2.8) seemed to fix this. How can I force this process affinity?

#2 Updated by danij about 14 years ago

"Seemingly random" in that to a user there does not seem to be a logical pattern; i.e., it does not crash every time the music repeats.

#3 Updated by filipetolhuizen about 14 years ago

I was wrong, the older library did not fix this. But I noticed it happens with the same midi all the time (the one from E1L6 - Cathedral)

#4 Updated by gobhuo about 14 years ago

If you don't want to limit Doomsday to a single core, you can write a plugin which plays non-MIDI sounds through native audio interfaces (DirectSound, ALSA,..) and uses SDL_mixer for MIDI only, and runs it out-of-process (like Chromium runs its plugins). For music, latency shouldn't be noticeable. IIRC linuxdoom also used a separate process for sounds (sndserv). Just an idea.

#5 Updated by skyjake over 13 years ago

Reduced priority as the default audio was switched to FMOD.

#6 Updated by danij about 12 years ago

- summary: [Windows] Crash caused by SDL_mixer (process affinity) --> [Windows] Crash caused by SDL_mixer
- assigned_to: Daniel Swanson --> nobody

#7 Updated by danij almost 11 years ago

Apparently this may be caused by an asynchronous callback: http://www.doomworld.com/vb/showthread.php?s=&postid=1180033#post1180033

#8 Updated by skyjake over 10 years ago

  • Tags set to Windows
  • Category set to Defect
  • Target version deleted (1.9.0-beta6)

#9 Updated by skyjake over 10 years ago

  • Tags changed from Windows to Windows, Audio

#10 Updated by skyjake over 4 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF