Project

General

Profile

Feature #2417

Is it possible to separate left and right shift to separate control bindings?

Added by vermil 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-03-10
% Done:

0%

Tags:

Description

Is it possible to separate left and right shift to separate control bindings?

I am currently forced to use a keyboard where the position of these controls would make it preferable to use the left shift key for run and the right shift key for move forward.


Related issues

Is duplicate of Feature #1758: Separate left/right modifier keys (Shift, Alt, etc.)New2014-04-18

History

#1 Updated by skyjake 3 months ago

  • Is duplicate of Feature #1758: Separate left/right modifier keys (Shift, Alt, etc.) added

#2 Updated by skyjake 3 months ago

  • Status changed from New to Closed
  • Assignee deleted (Deng Team)

In the 2.3 branch, no this isn't possible unfortunately due to limitations of the Qt framework. In 3.0 where SDL2 is being used for keyboard, yes the left/right Shift keys produce separate events.

However, 3.0 is not ready for gameplay at this time.

Also available in: Atom PDF