Project

General

Profile

Bug #2283

Pink Demons become Spectres

Added by 3DMaster almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Regression
Target version:
Start date:
2018-09-10
% Done:

100%


Description

So I don't like any of the old models in the jDoom Model Pack, except for the Spectre. The Spectre actually has the same-looking effect as the original spectre rather than just being transparent, and since you don't really see the bad modeling it works great.

So, I installed the Spectre but none of the other models; but now, strangely, most, but not all, pink demons become the Spectre model as well. For example, in e2l1, the demons up on top the green wall are supposed to be pink demons, but they're Spectres when I play with only the Spectre model picked.

Strangely I have seen the occasional pink demon, but it's been a while since I saw one that stayed a pink demon, and I just played through all of Ultimate Doom on Doomsday, and I think the last one I saw was somewhere in Episode 2, or was it even in episode 1?

Stay, you ask? Yes, stay, three times now, very far off into the distance I have seen a pink demon, which then once it gets a bit closer to me, or I look at it long enough - I can't tell, all of a sudden changes into the Spectre model. It's very strange.

Associated revisions

Revision 3632a3f9 (diff)
Added by skyjake over 1 year ago

Fixed|Renderer: Demons and Spectres get mixed up

Model frame interpolation links were set up incorrectly.

IssueID #2283

History

#1 Updated by skyjake over 1 year ago

  • Category set to Defect
  • Assignee set to skyjake
  • Target version set to 2.1 (Late 2018)

#2 Updated by skyjake over 1 year ago

  • Category changed from Defect to Regression
  • Status changed from New to Resolved
  • Priority changed from Normal to High
  • % Done changed from 0 to 100

This is a regression in the model metadata setup. Selectors were not considered when determining the frame progression of the models, so it started skipping between the regular demons and spectres in a weird way.

#3 Updated by skyjake over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF