Project

General

Profile

Bug #2183

Incomplete attachments uncaught exception (jdrp hud weapons)

Added by Drako over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
-
Start date:
2016-11-08
% Done:

100%

Tags:

Description

Build #2136. The uncaught exception incomplete attachments when the the 3d model of a HUD weapon (from jdrp pack) is going to be displayed.
Related to bug #1977 and feature #2116. In earlier builds the behavior was different http://dengine.net/forums/viewtopic.php?f=7&t=2310#p15310. It seems the problem can be fixed similarly as bug #1977.

doomsday.out (29.4 KB) doomsday.out Drako, 2016-11-08 06:17
doomsday.out (29.2 KB) doomsday.out Drako, 2016-11-09 05:49
doomsday.out (3.78 KB) doomsday.out 2140 Drako, 2016-11-10 06:52

Related issues

Related to Feature #2116: Compatibility with limited FBO functionality (old OpenGL drivers)Closed2015-02-13

Related to Bug #1977: Doomsday crashes with Intel ChipsetClosed2015-02-12

Associated revisions

Revision 404c4460 (diff)
Added by skyjake over 7 years ago

Fixed|Model Renderer: Graceful fallback for FBO config failure

If there is an error when setting up an alternative depth buffer for
3D weapon models, just clear the main depth buffer and render the
models there.

IssueID #2183

Revision 7245bcf4 (diff)
Added by skyjake over 7 years ago

Fixed|Model Renderer: Graceful fallback for FBO config failure

If there is an error when setting up an alternative depth buffer for
3D weapon models, just clear the main depth buffer and render the
models there.

IssueID #2183

Revision df90aada (diff)
Added by skyjake over 7 years ago

GL|libgui: Improved FBO configuration fallback

Instead of configuring the framebuffer in such a way that prevents
the renderer from working fully, render to a render buffer and apply
the same resolve-to-texture method that is used with antialiasing.

IssueID #2183

Revision 7b01cdb9 (diff)
Added by skyjake over 7 years ago

GL|libgui: Improved FBO configuration fallback

Instead of configuring the framebuffer in such a way that prevents
the renderer from working fully, render to a render buffer and apply
the same resolve-to-texture method that is used with antialiasing.

IssueID #2183

Revision c9e79533 (diff)
Added by skyjake over 7 years ago

libgui|GL: More fallback configurations for FBOs

GLFramebuffer now properly makes a distinction between depth-only
and depth/stencil attachments.

IssueID #2183

Revision f1cb63cf (diff)
Added by skyjake over 7 years ago

libgui|GL: More fallback configurations for FBOs

GLFramebuffer now properly makes a distinction between depth-only
and depth/stencil attachments.

IssueID #2183

History

#1 Updated by skyjake over 7 years ago

  • Tags changed from HUD to HUD, 3DModel, OpenGL
  • Category set to Defect
  • Status changed from New to In Progress
  • Assignee set to skyjake
  • Target version set to 49

Ok, I can see the problem here. I'll add an alternative rendering setup for the 3D weapon models if the framebuffer configuration warrants it.

#2 Updated by skyjake over 7 years ago

  • % Done changed from 0 to 100

Please try again with the next build...

#3 Updated by Drako over 7 years ago

Unfortunately, nothing changed. Still the same uncaught exception, even doomsday.out files look the same.

#4 Updated by skyjake over 7 years ago

  • % Done changed from 100 to 10

#5 Updated by skyjake over 7 years ago

Hmm, I'll try to simulate the errors in the output and see if that reveals anything.

#6 Updated by skyjake over 7 years ago

  • Related to Feature #2116: Compatibility with limited FBO functionality (old OpenGL drivers) added

#7 Updated by skyjake over 7 years ago

  • Related to Bug #1977: Doomsday crashes with Intel Chipset added

#8 Updated by skyjake over 7 years ago

  • % Done changed from 10 to 30

I did manage to reproduce the (or a) crash after simulating this failure scenario. I decided to try a different way to configure the framebuffer fallback now that the low-level GL setup has changed significantly. Let me know if the next build works any differently...

#9 Updated by Drako over 7 years ago

Now doomsday quits to windows immediately after the resolution change, before the rotating thing appears (the UI does not appear at all). Doomsday.out is much shorter...

#10 Updated by skyjake over 7 years ago

Ok, I've made another change for the next build. Now there are more fallback configurations and at least on my machine they all work as intended. There should now be a fallback that matches the configuration that used to work for you, according to the logs.

#11 Updated by skyjake over 7 years ago

  • % Done changed from 30 to 60

#12 Updated by skyjake over 7 years ago

The build number to try next is 2141...

#13 Updated by Drako over 7 years ago

The build 2141 seems to work as expected. For the first time since build 1.10.4 I am able to see 3D HUD weapon models. jdrp pack(s) work well (v 1.01 and (unofficial) 1.1, as well as jd3rp). Moreover, this bug: http://dengine.net/forums/viewtopic.php?f=7&t=2334#topic has been also fixed. Thanks.

#14 Updated by skyjake over 7 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 60 to 100

Great! Thanks for testing.

#15 Updated by skyjake over 7 years ago

  • Target version deleted (49)

Also available in: Atom PDF