Project

General

Profile

Bug #1860

[Doom] Final Doom teleporter quirk broken

Added by vermil over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2014-09-05
% Done:

100%


Description

Pretty much what the subject states; Dday no longer replicates the teleport quirk in Final Doom, where the players Z height isn't set to the floor of the location sector. The feature appears to have broken at some point.

Associated revisions

Revision 90b22cbd (diff)
Added by danij almost 9 years ago

Fixed|Doom: Final Doom teleport destination altitude (regression)

A simple mix up - global var gameMode is gamemode_t and should be
compared with values in that enum, rather than the GM_* flags which
are intended for use with global var gameModeBits.

See: http://doomwiki.org/wiki/Final_Doom_teleporters_do_not_set_Z_coordinate

IssueID #1860

History

#1 Updated by danij almost 9 years ago

  • Status changed from New to In Progress
  • Assignee set to danij

#2 Updated by danij almost 9 years ago

  • % Done changed from 0 to 90

#3 Updated by danij almost 9 years ago

  • Status changed from In Progress to Resolved
  • Target version set to 1.15
  • % Done changed from 90 to 100

#4 Updated by danij almost 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF