Project

General

Profile

Bug #1804

[Hexen] Puzzle progress in main hub not showing up

Added by adamcirillo about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Deng Team
Category:
Regression
Target version:
Start date:
2014-05-18
% Done:

100%

Tags:

Description

When in hexen the switches you pull to solve puzzles sometimes don't trigger the events in other maps for e.g. when I pulled the switch to solve 1 sixth of the puzzle for the shadow wood hub the area would not light up. I've attached a save where I pulled all 6 switches yet only four have lit up. Also happed in heresiarch's Seminary as well pull one switch to solve one ninth of the puzzle yet the section is not lit up. I think it might be a save bug as it was lit up when I saved but when I loaded my save I was back at the previous point in wolf chapel I saved before going through the portal and then again after when I loaded back up I was at the portal before I went through and when I went through again that's when the switch didn't light up.

hex0.save (85.1 KB) hex0.save adamcirillo, 2014-05-18 23:09
hex1.save (134 KB) hex1.save adamcirillo, 2014-05-18 23:09
hex2.save (112 KB) hex2.save adamcirillo, 2014-05-18 23:09
doomsday.out (29.1 KB) doomsday.out adamcirillo, 2014-05-19 22:07

Associated revisions

Revision 86907599 (diff)
Added by danij about 6 years ago

Fixed|Hexen|ACScript: Deferred ACScript task management

Due to a refactoring oversight, the deferred ACS task list was being
mismanaged when attempting to run the tasks when returning to a map
which had been visited previously.

IssueID #1804

Revision ed3511c5 (diff)
Added by danij about 6 years ago

Fixed|Hexen|ACScript: Deferred ACScript task management

Due to a refactoring oversight, the deferred ACS task list was being
mismanaged when attempting to run the tasks when returning to a map
which had been visited previously.

IssueID #1804

History

#1 Updated by skyjake about 6 years ago

  • Tags set to Hexen
  • Subject changed from Puzzle progress in main hub not showing up to [Hexen] Puzzle progress in main hub not showing up
  • Category set to Regression
  • Priority changed from High to Urgent

#2 Updated by skyjake about 6 years ago

Which version of Doomsday are you using? (1.14.3?)

#3 Updated by skyjake about 6 years ago

  • Status changed from New to In Progress
  • Assignee set to Deng Team
  • Target version set to 1.14.4

#4 Updated by adamcirillo about 6 years ago

1.14.3

#5 Updated by danij about 6 years ago

Note that there are numerous bugs in Hexen's ACS and it could be that the user has encountered one and now, his game state is invalid. These are issues which affect all ports supporting Hexen, not just Doomsday.

So far I have been unable to replicate the reported issue myself, in 1.14.3

#6 Updated by vermil about 6 years ago

I've just given the Shadow Wood hub a test in the latest unstable build by going through each sub map with noclipping and pressing all six switches.

Trying to load a save game made on Shadow Wood, after all six switches are pressed causes Dday to repeatedly hang. I also had Dday crash a few seconds after returning to Shadow Wood after all six switches had been pressed, on one occasion.

Also, I tried pressing two of the six switches, returning to Shadow Wood (to check the panels had lit up) and then heading to one of the sub maps to save the game. This time the save game loaded, however when I then went back to Shadow Wood to check the panels, I found they were no longer lit up and the game was in-completable, as the switches were still pulled on the sub maps.

#7 Updated by danij about 6 years ago

This is beginning to sound like another FS2 issue...

#8 Updated by skyjake about 6 years ago

vermil wrote:

Trying to load a save game made on Shadow Wood, after all six switches are pressed causes Dday to repeatedly hang.

Could you attach this save game here, please?

#9 Updated by vermil about 6 years ago

When trying to load a save game made on Shadow Wood after all six switches have been pressed on the sub maps, the alert log comes up right before Dday freezes.

Upon checking my out file, I found this:

Loading game from "/home/savegames/hexen/hex1.save"...
S_StartMusic: Starting music 'currentmap'
Loading map "MAP13"...
Current map elements:
1865 Lines
355 Sectors
2363 Vertexes
4 Polyobjs
Z_CheckHeap: invalid total size of blocks (33524320 != 33554384)
Z_CheckHeap: zone book-keeping is wrong
Application terminated due to exception:
Z_CheckHeap: zone book-keeping is wrong

There is no more in the out file after the last line.

That said, restarting Dday and then trying to load the save game, appears to lead to it being loaded without issue. It seems the freeze may only occur if the save game is loaded in the same game session it was created in. But it seems reproducible.

#10 Updated by skyjake about 6 years ago

vermil wrote:

Z_CheckHeap: invalid total size of blocks (33524320 != 33554384)
Z_CheckHeap: zone book-keeping is wrong

One potential cause for this is an out-of-bounds write in the memory zone. Should run a few tests with "deng_fakememoryzone" and GuardMalloc...

EDIT: I couldn't locate a memory zone write error, although that doesn't rule out the possibility that there still might be one.

#11 Updated by skyjake about 6 years ago

adamcirillo: Were you using a resource pack of some kind with the attached saves?

If you also attach your doomsday.out, that will tell us all the relevant information.

#12 Updated by danij about 6 years ago

I'm also looking into this. My hunch is that the memory zone book-keeping error and the failed puzzle activation are both caused by the same issue.

Edit: Yep, they were indeed one and the same issue. (Fix committed).

#13 Updated by adamcirillo about 6 years ago

yeah i'm using some resource packs I just attached the doomsday.out you requested

#14 Updated by danij about 6 years ago

  • % Done changed from 0 to 100

#15 Updated by danij about 6 years ago

  • Status changed from In Progress to Closed

#16 Updated by vittau almost 6 years ago

danij wrote:

I'm also looking into this. My hunch is that the memory zone book-keeping error and the failed puzzle activation are both caused by the same issue.

Edit: Yep, they were indeed one and the same issue. (Fix committed).

It just happened to me yesterday, using 1.14.5. Pressed all the six switches in Shadow Wood (and double checked them all to make sure), and when I went to the door only 2 were actually lit up. Had to noclip to carry on with the game...

#17 Updated by vittau almost 6 years ago

Then again, my game was started on an older version (can't remember if .3 or .4), so I guess the .sav file was probably already corrupted?

#18 Updated by danij almost 6 years ago

vittau wrote:

I guess the .sav file was probably already corrupted?

Possibly not, this may be Issue #1846 related. Lets see what happens once that is fixed.

Also available in: Atom PDF