Project

General

Profile

Bug #1713

[HEXEN] Guardian of Steel switches not animating as intended

Added by nyakze over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Regression
Target version:
-
Start date:
2014-01-16
% Done:

0%


Description

The switches in the Guardian of Steel should only work when you press them 2 times in a row, it will make them to hold their new position and move a wall. For some reason, I cannot press on them 2 times and which makes it impossible to advance further. Also, when I press it the second time, the sound for the first press stops and it hasn't been like this before, both sounds should be hearable.
I'm currently on version 1.13.2, it previously worked on versions 1.9.0 beta and 1.8.6 (didn't try other versions).

History

#1 Updated by vermil over 10 years ago

To which switches do you refer to?

The switches that move the walls appear to be functioning fine for me; they are repeatable, activate on a single use and don't hold, which is how they should function.

#2 Updated by nyakze over 10 years ago

vermil wrote:

The switches that move the walls appear to be functioning fine for me; they are repeatable, activate on a single use and don't hold, which is how they should function.

No, it's not the original behavior. The switches in Guardian of Steel are different.
I've made videos to proof my case:
Original behavior (1.8.6): http://youtu.be/zSkY_0twq1E
Current (broken) behavior: http://youtu.be/9iMJxzM_mp0
With the current behavior the switches do nothing, with the original they used to move the wall in the place to which you go down in elevator, where there is a different switch that solves one third (i think) of the seven portals' puzzle

#3 Updated by nyakze over 10 years ago

I'm pretty sure there were a couple more of switches like that ahead in the game also, can't remember which levels though. So it might be a game-breaking bug.

#4 Updated by vermil over 10 years ago

Ah, you are referring to the animation of the switch texture, rather than it's function. My apologies for misinterpreting.

I personally, can reproduce the supposedly broken switch animation (i.e what yourself is showing in your broken behavior video) in both 1.8.6 and 1.13 by pressing it quickly in both.

I imagine the broken animation is caused by an oversight in the script that the switch calls.

My tests also show that no matter how the switch texture animates, that said script (I.e the function of the switch) always seems to be carried out correctly (i.e it correctly moves the walls no matter).

#5 Updated by danij over 10 years ago

  • Subject changed from [HEXEN] Guardian of Steel switches not working as intended to [HEXEN] Guardian of Steel switches not animating as intended

#6 Updated by nyakze over 10 years ago

Err, no. That's not just animation. In 1.13.2 the switches don't move the wall for me no matter how many times I press them...

#7 Updated by nyakze over 10 years ago

I'm sorry, I was wrong. You actually have to only press it once now, instead of 2 times like in original Hexen. So it does indeed work, but differently. Sorry.

#8 Updated by nyakze over 10 years ago

LOL, I just tried it and pressing it once works in original as well, this can be closed, sorry i wasted your time :s

#9 Updated by skyjake over 10 years ago

  • Status changed from New to Rejected
  • Priority changed from High to Normal

Also available in: Atom PDF