Project

General

Profile

Bug #2327

[Heretic] Linetype 98 is nonfunctional

Added by vermil about 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Regression
Target version:
Start date:
2019-04-18
% Done:

100%

Tags:

Description

Linetype 98 is in functional in Heretic; it does nothing.

The same linetype appears to work fine in Doom.

http://talk.dengine.net/discussion/2696/wr-floor-lower-to-8-above-highest-floor-action-does-not-work

Associated revisions

Revision 3a4b63be (diff)
Added by skyjake 6 months ago

Fixed|Heretic: Line special 98 is missing

IssueID #2327

History

#1 Updated by skyjake 6 months ago

  • Category set to Regression
  • Status changed from New to In Progress
  • Assignee set to skyjake
  • Target version changed from 2.2.x to 2.2 (2019)
  • % Done changed from 0 to 100

Line special 98 was completely missing from p_spec.cpp in Heretic.

Now using code from vanilla Heretic. Please test to see if this works as intended.

#2 Updated by skyjake 6 months ago

  • Status changed from In Progress to Resolved

#3 Updated by skyjake 6 months ago

  • Subject changed from Linetype 98 is in functional in Heretic to [Heretic] Linetype 98 is nonfunctional

#4 Updated by skyjake 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF