Project

General

Profile

Bug #2300

[Doom] Secret exit switch in E3M6 placed too low

Added by sonicdoommario over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2018-12-10
% Done:

100%

Tags:

Description

I remember this being an issue in an earlier version of Doomsday (1.9.10 I believe), where the secret exit switch in E3M6 wasn't even visible. While it is visible now, I noticed that it is still positioned too low compared to where it is in Vanilla Doom. I attached two screenshots comparing the position of switch between Chocolate Doom and Doomsday.

e3m6switch-chocolate.png (171 KB) e3m6switch-chocolate.png sonicdoommario, 2018-12-10 07:03
e3m6switch-doomsday.png (818 KB) e3m6switch-doomsday.png sonicdoommario, 2018-12-10 07:03

Associated revisions

Revision ee54cd23 (diff)
Added by skyjake 7 months ago

Fixed|Renderer: Lower texture alignment in E3M6

This is perhaps an uncommon situation, where there is a switch on the front lower texture, but the back sector ceiling is higher than the front ceiling.

IssueID #2300

History

#1 Updated by skyjake over 1 year ago

  • Target version set to 2.1.1

#2 Updated by skyjake over 1 year ago

  • Category set to Defect
  • Assignee set to skyjake

#3 Updated by skyjake over 1 year ago

  • Target version changed from 2.1.1 to 2.1.2

#4 Updated by skyjake 9 months ago

  • Target version changed from 2.1.2 to 2.2 (2019)

#5 Updated by skyjake 7 months ago

For future reference, the problem is likely around walledge.cpp:323, and pertains to material origin calculation of the lower wall section of a line with the lower unpegged flag.

See also: https://doomwiki.org/wiki/Texture_alignment

#6 Updated by skyjake 7 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied a fix. Please test if this causes regressions elsewhere...

#7 Updated by sonicdoommario 7 months ago

Played through Ultimate Doom and didn't notice anything broken, the switch also displays properly now, thanks!

#8 Updated by skyjake 7 months ago

Great, thanks!

#9 Updated by skyjake 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF