Project

General

Profile

Bug #2277

(linux/ubuntu) doomsday-server is only sending the default port to the master list.

Added by tacgnol about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Defect
Target version:
Start date:
2018-08-10
% Done:

100%


Description

Hello, after some troubleshooting from this thread : http://talk.dengine.net/discussion/2569/multiple-public-server-issue

It seems that with the ubuntu linux package, the doomsday-server program is sending the default port instead of the specified port.

I believe the local discovery with UDP is working properly, i can see the proper port on the lan. The issue is only with the public master list.

I tried the same config with a windows build, and it was working properly with the correct specified port being advertised.

Associated revisions

Revision c6c64af9 (diff)
Added by skyjake about 4 years ago

Fixed|Server: Server's port not included in master server announcement

In case the local IP address was not determined and "net-ip-address"
was not set, the server's port was omitted from the master server
announcement.

IssueID #2277

History

#1 Updated by skyjake about 4 years ago

  • Category set to Defect
  • Assignee set to skyjake
  • Priority changed from Normal to High
  • Target version set to 2.1 (Late 2018)

#2 Updated by skyjake about 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#3 Updated by tacgnol about 4 years ago

Working great, thanks !

#4 Updated by skyjake about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF