Project

General

Profile

Feature #1682

[UI] Button click behavior outside an open popup

Added by eunbolt over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
User experience
Target version:
Start date:
2013-12-17
% Done:

100%

Tags:
UI

Description

Switching between the video and render sub-menus
You are in the "Render" sub-menu and you want to go to the "video" sub-menu, so you click on "video", that makes the "render" sub-menu disappear, but the "video" sub-menu doesn't appear, so you have to click on the "video" sub-menu again for it to appear.

Associated revisions

Revision 62700d29 (diff)
Added by skyjake over 8 years ago

UI|Client: Popups allow clicking through to widgets outside the popup

As a special case, mouse clicks on interactive widgets are allowed
to occur: even though the popup is open, it offers the event to
whichever widget is being hit even though the popup dismissal will
then eat the event and close the popup.

IssueID #1682

History

#1 Updated by skyjake over 8 years ago

  • Tags set to UI
  • Tracker changed from Bug to Feature
  • Subject changed from menu (user interface) problem to [UI] Button click behavior outside an open popup
  • Category set to User experience
  • Assignee set to skyjake

This is the intended behavior at the moment. All popups are dismissed with a click outside the popup -- the dismissal currently eats the event and it doesn't get passed to any further widgets.

I agree it would be better that buttons outside a popup would react even though the popup is dismissed by the click.

#2 Updated by skyjake over 8 years ago

  • Status changed from New to In Progress

#3 Updated by skyjake over 8 years ago

  • Status changed from In Progress to Closed
  • Target version set to 1.13
  • % Done changed from 0 to 100

Also available in: Atom PDF