Project

General

Profile

Bug #1098

"Application Terminated due to Exception" messaging when qutting Doomsday

Added by sonicdoommario almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2012-11-02
% Done:

100%


Description

I was just testing some stuff out in the latest build of Doomsday (build 661) and I get an error message every time I exit Doomsday, which says "Application terminated due to exception - no RTTI data!"

I have a Windows 7 64-bit machine with an Intel 3000 graphics card.

This error message also screwed up my resolution and monitor display. Here is a screenshot of what happened.

Attached is a copy of my doomsday.out file.

Labels: Display Mode, Windows, Window Manager

Attachments:

History

#1 Updated by skyjake almost 10 years ago

Is this still happening with current builds (>= 710)?

#2 Updated by sonicdoommario almost 10 years ago

I was not getting the error with Build 703, but I believe I was getting it with Build 700. In addition, I was not getting it with Build 693, so it's been a bit inconsistent.

Doomsday is not launching for me on Build 707, so I will wait for tomorrow's build to try again, so hopefully this error is resolved.

#3 Updated by sonicdoommario over 9 years ago

Yes, to follow up, this issue has re-appeared in Build 710.

#4 Updated by sonicdoommario over 9 years ago

To be further specific, I will only get this error if I change the resolution in Doomsday. I set the resolution down from 1650x900 (my laptop's native resolution) to 1182x864, and I got the error message. And the resolution change is not saving, despite me choosing to set the new resolution as the default, so it must be caused by this error message.

#5 Updated by skyjake over 9 years ago

- labels: --> Display Mode, Windows, Window Manager
- status: open --> fixed
- priority: 1 --> 7

#6 Updated by skyjake over 9 years ago

This should now be fixed for 1.9.10. On Windows, there was a problem destroying the main window that caused a null pointer access elsewhere in the engine.

#7 Updated by skyjake over 9 years ago

- assigned_to: Jaakko Keränen

Also available in: Atom PDF