Project

General

Profile

Bug #2198

[HeXen] Crash when going through portals with wings (trying to unlock map06 in hub1)

Added by theleo_ua about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
-
Start date:
2017-02-07
% Done:

0%

Tags:

Description

[HeXen] Crash when going through portals with wings (trying to unlock map06 in hub1)

1) Start hexen original
2) Go to map03 (visit03 cheat is acceptable)
3) enter casper and indiana cheats
4) go to secret exit to map04 (you should enter casper cheat again to enter the portal)
5) activate wings of wrath in map04
6) try to solve "one half of the secret puzzle in map04"
7) go to the portal to map02

actual result: crash
expected result: player is teleported to map02 with activated wings
workaround: do not activate wings unless map06 is unlocked

Bus is reproduced in live stream, so here is the video demonstration: https://www.youtube.com/watch?v=zinx1oStuz0&index=8&list=PL5QwAqOy7WABpsDsuzSKwTk2S8QnzsLg5#t=1h59m50s (watch from 1:53:15 (collecting wings at map 02) to 1:59:50 (crash) )

Doomsday.out attached

Reproduced in 1.15.8

doomsday.out (37.8 KB) doomsday.out theleo_ua, 2017-02-07 01:11

History

#1 Updated by skyjake about 7 years ago

  • Tags set to Hexen, Gameplay
  • Category set to Defect
  • Status changed from New to In Progress
  • Assignee changed from Deng Team to skyjake

#2 Updated by skyjake about 7 years ago

  • Status changed from In Progress to Resolved

I can definitely replicate the crash using 1.15.8. It looks like issue #2061, but that was marked as fixed in May 2015 (during the 1.15 RC period).

I believe the bug was actually only fixed in June 2016 by fb624179aa. I could not reproduce the crash in recent 2.0 builds.

#3 Updated by skyjake almost 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF