Project

General

Profile

Bug #2106

[OS X 10.11 El Capitan] Mouse cursor does not stay hidden

Added by skyjake over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Regression
Target version:
Start date:
2015-08-03
% Done:

100%


Description

The new "cursor wiggle zoom" feature of El Capitan causes the mouse cursor to keep popping up while playing the game.

Backport 0c871f83 to the stable branch where the problem is fixed by using native APIs to control mouse visibility. (Conceivably a future version of Qt will also address this.)

Associated revisions

Revision c6921709 (diff)
Added by skyjake over 3 years ago

Fixed|OS X: Mouse cursor does not stay hidden in OS X 10.11

Backported from the master branch.

IssueID #2106

History

#1 Updated by skyjake over 3 years ago

  • % Done changed from 0 to 90

#2 Updated by skyjake over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

#3 Updated by skyjake over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF