Project

General

Profile

Bug #2076

FluidSynth uses deprecated GLib threading API (OS X)

Added by skyjake over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Regression
Target version:
Start date:
2015-06-01
% Done:

100%

Tags:

Description

Even in the latest version of FluidSynth (1.1.6), they are using GLib threading functions that were deprecated in GLib 2.32. These must be removed since they will eventually stop working.

Currently only the OS X build uses the embedded version of FluidSynth, so Linux and Windows are not affected by this issue at the moment.

History

#1 Updated by skyjake over 8 years ago

  • Description updated (diff)

#2 Updated by skyjake over 8 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF