Project

General

Profile

Bug #1972

[MP] Fast-moving planes not always reach destination on client-side

Added by skyjake over 5 years ago. Updated almost 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Defect
Target version:
Start date:
2015-02-11
% Done:

0%


Description

When playing on a remote server with a ping of ~250ms, sometimes fast-moving planes do not reach their destination but rather stop one tic's (?) distance from the target height.

MP setup: coop Doom II MAP26 with plenty of moving enemies.

History

#1 Updated by skyjake over 5 years ago

  • Description updated (diff)

#2 Updated by skyjake about 5 years ago

  • Target version set to 50

#3 Updated by skyjake about 5 years ago

  • Subject changed from [Multiplayer] Fast-moving planes not always reach destination on client-side to [MP] Fast-moving planes not always reach destination on client-side

#4 Updated by skyjake about 5 years ago

  • Assignee set to skyjake

#5 Updated by skyjake about 5 years ago

  • Assignee deleted (skyjake)
  • Priority changed from Urgent to Normal

I ran a couple of further tests on MAP26 with build 1587. I tried reproducing the error on a ping of 100 ms, and another time with 500 ms. In both cases, plane movement worked correctly. It is possible that the error will be triggered when delta traffic gets congested, or when the server is in a particular state. The original issue was triggered after playing through several maps on the server.

Lowering priority because this doesn't seem easily reproducible.

#6 Updated by skyjake about 5 years ago

  • Target version deleted (50)

#7 Updated by skyjake about 4 years ago

  • Target version set to 2.1 (Late 2018)

#8 Updated by skyjake almost 2 years ago

  • Target version changed from 2.1 (Late 2018) to Multiplayer

Also available in: Atom PDF